Failed to authenticate to Maestro

Hi,

I followed this blog post Deploying Python bots using BotCity Maestro to deploy my first bot, but I BotCLI is failing to authenticate:
“Login failed. Check your internet connection, server availability or SERVER parameter in config.properties
Invalid Login. Check your credentials in config.properties”

I filled in the config.properties with the following infos:
organization= [same as my workspace]
server=http://developers.botcity.dev
login= [same as the user to login]
key= [same as Maestro’s Developer Environment menu]

I’m running BotCLI 1.6 on linux machine - Pop! OS

Can I schedule tasks using a community license only?

Thank you!

Hi @jamaral,

Could you please try to change your server= to:

server=http://developers.botcity.dev/

Please note the / at the end of the URL. I believe that this is a bug which affected the version 1.6 that is fixed in a newer version to be released soon.

Let me know if that works.

About your other questions, at this moment using the Community License you can schedule tasks but you can only have 1 Runner and 1 Activity. Please refer to the BotCity Terms of Service for more information.

1 Like

Hi @hhslepicka ,

Thank you for supporting me. I applied the changes to the config files, unfortunately, I’m still facing issues when I try to connect to BotCity, though.

On the bright side the error message has changed to ‘Invalid Login. Check your credentials in config.properties’ only.

I have also tried to connect using BotRunner and the error message says I have supplied the wrong access key. I have double-checked it though and it seems I am using the correct one.

@jamaral could you try to add into your configuration file a new key-value pair in which the key is:
workspace= and the value is the same as your login and let me know how it goes?

1 Like

@hhslepicka

I managed to login and publish my first bot to Maestro - as shown in the attached screenshots. The problem now is that I can’t pull bots using bot runner. I have also added to BotRunner’s config the key-value mentioned, but I got the same result. Could please assist me on this?



@jamaral I will send you a meeting link via Slack.