I went to look at the download I made from Botcity and I saw that it doesn't have the setup.py script

I’m trying to run the project available in Python and I’m getting an error. I downloaded Botcity Studio and when I ran the project I got an error in the setup.py script and in the pyproject.toml file. I went to look at the download I made from Botcity and I saw that it doesn’t have the setup.py script. and this gives an error when I put ‘pip install -e .’ to install.
Can you help me?

Hello @andersoncesar,

One question, which project template are you using?

The current one, in this case is this one: Python "Hello Bot" - BotCity - Python RPA

Or the legacy template, which is this one: Python "Hello Bot" - BotCity - Python RPA

If you are using the legacy template, you need to run the command pip install -e . at the same level as the setup.py file, that is, in the path of the root folder of your project.

The setup.py file will always be located in the root folder of the legacy project.

If the above process works, you’ll probably be able to run the automation you want.

If the problem persists, please send us a print of the error that is being thrown and your project’s folder structure. That way, we can help you better.

Uploading: Capturar.PNG…
Legacy Botcity follows the documentation and does not have the setup.py executable to continue.

It keeps giving this error Robo does not appear to be a Python project: neither ‘setup.py’ nor ‘pyproject.toml’ found.

Hi @andersoncesar,

I was unable to access the file uploaded above. You must wait for the file to fully load before sending the response when uploading. Can you send me again?

As for the setup.py and the error, I did a test by creating a legacy template, and in my project, the setup.py file is present, as you can see in the image below. In this image, I also pointed the project root folder path to run the pip install -e.

In this second image, I reproduced the same error as you when running pip install -e in a folder different from the project’s root folder, that is, without being at the same level as the setup.py file.

Could you confirm that your project has the same structure as the image and check the path where the pip command is running?

Hello, Livia,
Now I managed to load the screenshot. path is the same as the folder
Uploading: Capturar.PNG…

Hi @andersoncesar

This is the new template. In this case, it is necessary to run the command:

pip install --upgrade -r requirements.txt

When finish downloading the packages, the VS Code already recognizes the BotCity packages, if that doesn’t happen, close the project in your VS code and reopen it again, that should solve it.

With the packages properly downloaded, just run the command python bot.py in the terminal, and your bot should start.